Problem with Order 89 - Attacking Forts

This topic thread is for any issues with turns that you are having, such as garbled printouts, etc. should be posted here. This will help us address problems and glitches with email, etc. We will also post suggestions here for fixes to specific issues.

This is not a gripe board, this is a troubleshooting board. Don’t just say “My turn didn’t work.” be as specific as possible. That way we can work together to fix the issue and make the game better for everyone.

Moderator: Tregonsee

Re: Problem with Order 89 - Attacking Forts

Postby CHARON EMPIRE » Thu Mar 29, 2018 10:48 pm

Look at the on line action code for code 89. You'll find it on the input turn page. You will see a location one and two.

89 Missile Strike Against Forts + Move Fleet XXX2324 80 XXX23248 20

I think the problem with the code sheet your looking at it doesn't take into account this is now a move and do action, meaning location one is where the fleet is attacking from and location 2 is the target. Before you had to first move the fleet to a system, planet within the system, or subsector and then on the following action order the fleet to attack the planet. The later is what the tec sheet you have references and it does need updated.

That said, the codes on the input page I do believe Thom has updated them all. But the rule book is not correct nor is the sheet which you received at tec 17. I don't know if the new sheets for tec 17 reference the change or not, you would have to ask Thom that.
User avatar
CHARON EMPIRE
 
Posts: 149
Joined: Tue Aug 19, 2014 4:04 pm

Re: Problem with Order 89 - Attacking Forts

Postby Framis » Fri Mar 30, 2018 11:02 am

Thanks for the pointer. I guess I'll go through the input page and update my Tec sheets as needed.
User avatar
Framis
 
Posts: 46
Joined: Sun Oct 09, 2016 4:47 pm

Re: Problem with Order 89 - Attacking Forts

Postby CHARON EMPIRE » Tue Apr 03, 2018 7:04 pm

How did the missile attacks go with two locations?
User avatar
CHARON EMPIRE
 
Posts: 149
Joined: Tue Aug 19, 2014 4:04 pm

Re: Problem with Order 89 - Attacking Forts

Postby Framis » Tue Apr 03, 2018 10:39 pm

Didn't do attacks this turn. I had Real Life stuff going on and had to send in the turn very early. Will try this week.
\
User avatar
Framis
 
Posts: 46
Joined: Sun Oct 09, 2016 4:47 pm

Re: Problem with Order 89 - Attacking Forts

Postby Framis » Sun Apr 08, 2018 2:47 pm

Well, I did the attack orders with both a location 1 and 2. Blank line on the printout, missiles not expended. The forts I has spotted there might not have been there. Perhaps that is the problem?
User avatar
Framis
 
Posts: 46
Joined: Sun Oct 09, 2016 4:47 pm

Re: Problem with Order 89 - Attacking Forts

Postby REPTIMALIEN » Sun Apr 08, 2018 3:33 pm

I do find sometimes when scanning with fleets that have some fire power, when the forts try to attack the scanning fleet, that the fleet destroys the forts.
REPTIMALIEN
 
Posts: 101
Joined: Tue Aug 19, 2014 8:57 pm

Re: Problem with Order 89 - Attacking Forts

Postby Tregonsee » Sun Apr 08, 2018 7:25 pm

Framis wrote:Well, I did the attack orders with both a location 1 and 2. Blank line on the printout, missiles not expended. The forts I has spotted there might not have been there. Perhaps that is the problem?


Location #1 should be in the same system as Location #2 (system space or another planet in the system), unless you are over TL 60, in which case you can be is sub-sector space but in the same sub-sector.
User avatar
Tregonsee
 
Posts: 140
Joined: Mon Aug 18, 2014 10:02 pm

Re: Problem with Order 89 - Attacking Forts

Postby Framis » Mon Apr 09, 2018 8:10 am

I was already in orbit over the target planet.
User avatar
Framis
 
Posts: 46
Joined: Sun Oct 09, 2016 4:47 pm

Re: Problem with Order 89 - Attacking Forts

Postby CHARON EMPIRE » Mon Apr 09, 2018 3:50 pm

Try it from a location other than the orbit of the planet, either that someone else has already destroyed the forts?
User avatar
CHARON EMPIRE
 
Posts: 149
Joined: Tue Aug 19, 2014 4:04 pm

Re: Problem with Order 89 - Attacking Forts

Postby Thom » Sun Apr 15, 2018 11:24 am

Sorry about taking so long to reply. First you can use the old code where you only need the target planet in the first location. This assumes the fleet is in strike position already. You can also use the new code which is a move and do where the first location is the position to move the fleet and the second location is the target planet. Either will work. When I updated most actions to move and do I made sure to have the game remain compatible with the old action codes as many players were used to the old game and I didn't want to mess up their game.

Now having said that, there is one thing that does not work. That is when you send the fleet to the planet orbit of the planet you wish to attack and then try and start a missile strike from there. This has nothing to do with the new move and do code but was a flaw, or maybe a feature, in the game. If you send a missile strike and the planet has a fleet in orbit the fleet will try and intercept the missile strike coming in if the owner of the planet and the fleet in orbit are either one and the same or allied. Unfortunately when you are in orbit over a planet the game thinks you are already allied with the planet owner since your fleet is in orbit and was not attacked. So the fleet in orbit tries to intercept the attacking fleet, which is one and the same, and since the two fleets are allied (really they are the same) there is no interception. However it does trigger the planet defenses thus having the fleet fight the planet defenses without launching any missiles. However since the aggression level of the planet and the fleet do not equal 100% nothing happens and you get no report.

This was found by a player last game. I think I told the player not to do that and made a quick change to the code to alert the players not to do that. But the one line of code with the message seems to be missing. I'll add that message back in again.
Thom
 
Posts: 155
Joined: Sun Aug 17, 2014 10:34 am

PreviousNext

Return to Troubleshooting Board

Who is online

Users browsing this forum: No registered users and 1 guest

cron